Chào các bác, tình hình em đang muốn cài VBB 4.2.0 nhưng lại gặp lỗi này mặc dù thông tin config rất chuẩn rồi :

Code:
Database error in vBulletin :

mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead
/home/domain.com/public_html/includes/class_core.php on line 317

MySQL Error   : 
Error Number  : 
Request Date  : Wednesday, December 26th 2018 @ 12:08:51 PM
Error Date    : Wednesday, December 26th 2018 @ 12:08:51 PM
Script        : http://domain.com/install/
Referrer      : 
IP Address    : XXXXXXXX
Username      : 
Classname     : vB_Database
MySQL Version :
Em dùng PHP 5.6 vì chọn PHP 7.1 thì lỗi không hiện ra cái này luôn. Dòng 317 của file class-core.php đây ạ :

PHP Code:
// catch_db_error will handle exiting, no infinite loop here
        
do
        {
            
$link $this->functions[$usepconnect 'pconnect' 'connect']("$servername:$port"$username$password);
        }
        while (
$link == false AND $this->reporterror); 
Em gà mờ, mong mọi người giúp đỡ